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Mi-101 Mathematica 2004-2005

Rédaction avec Mathematica

Objectifs :
- utiliser la structuration de documents
- utiliser les notations usuelles et scientifiques
- créer ses propres notations
- générer un index et un sommaire

1- Introduction

La rédaction et la présentation de textes scientifiques font apparaitre de nombreuses difficultés de mise en page et
de formatage des symboles.

S'il est exact que TgX et IRTEX représentent le parfait exemple du logiciel libre réussi, il n'en est pas moins vrai que
le processus de rédaction-compilation peut sembler compliqué au néophyte issu du monde Word et de son Wysi-
wyg.

Les possibilités offertes par le langage du notebook Mathematica présentent une alternative a qui voudra rédiger
de courts textes scientifiques, ou bien son travail Mathematica.

A Theure actuelle, quelques revues de biologie ou de sciences physique acceptent la soumission d'articles au
format notebook Mathematica .

2- Les bases

Environnement texte
Lors de l'ouverture de Mathematica, le cahier (Notebook) se présente comme une feuille blanche, espace de travail

dans lequel s'insereront textes, graphiques, lignes de code et formules mathématiques.

Afin de mieux contrdler la présentation d'un article, il est plus commode de faire apparaitre la régle ainsi que la
barre d'outils, disponible via Format > Show Ruler ou Format > Show toolbar.

La premiére permet le contrdle de largeur de la page et I'espacement des tabulations, la seconde affiche les rac-
courcis de justification et d'impression.

W Mise en forme du texte

11 existe deux principaux styles de textes (Cf Feuille de style ), le style Text proprement dit tel qu'il est employé
ici, et le style dérivé Input tel qu'il est employé 1la (ce dernier étant utilisé pour fournir des com-
mandes a Mathematica).

On peut sélectionner l'un ou l'autre en le choisissant dans le menu déroulant a I'extrémité gauche de la barre
d'outils, ou respectivement par les raccourcis Shift-Alt-7 et Shifi-Alt-9.

Les commandes de casse classiques s'utilisent en mode texte, via les raccourcis Ctrl-B pour le gras (Bold), Ctri-I
pour l'italique et Ctrl-U pour le souligné (Underline).
Le choix de police de caractére se fait par Format > Font.

En ce qui concerne les sauts de pages, ils ne sont visibles que si I'option est cochée dans Format. Pour spécifier
un saut de page au dessus, au dessous ou a l'intérieur d'une cellule, I'option est a chercher dans 1'Option Inspector :
en sélectionnant la cellule concernée, puis l'intitulé Selection dans le menu déroulant de 1'Option Inspector, section
Cell Options, sous-section Page Breaking.

Le WYSIWYG

Le cahier Mathematica utilise son propre langage, qui grace a une structure proche de celle des conventions
typographiques, permet la création d'expressions structurellement complexes (telle l'intégrale d'une fraction
rationnelle sur une ligne comportant du texte).

Le cahier est donc sans cesse rafraichi afin de prendre en compte les modifications parfois significatives qui sont
apparues. Ceci fournit une interface semi-WYSIWYG a l'utilisateur, qui peut notamment observer l'effet de la
redimension des marges de mise en page sur son texte.

Afin d'offrir au rédacteur un apercu de son texte imprimé, Mathematica inclut un mode Format > Screen Style
Environnement > Print Out qui adapte le zoom de l'affichage écran a une simulation du rendu papier. On peut
aussi y accéder en cochant Format > Show Page Breaks.

3- Rédaction de mathématiques

L'option Traditional Form

Par défaut, le contenu des cellules est affiché en utilisant les conventions regroupées sous la dénomination Stan-
dard Form. Généralement, les conventions mathématiques ne sont pas celles des textes informatiques habituelles :
celles-ci sont regroupées sous la dénomination Traditional Form.

Le choix d'utilisation des conventions Traditional Form peut étre fait au niveau global (pour I'ensemble du docu-
ment) ou localement, pour certaines cellules seulement.

Bien que Mathematica donne la possibilité au rédacteur de représenter toutes les entrées et sorties du cahier en
Traditional Form (Cell > Default Input/Output > Traditional Form), certaines expressions entrées en
Traditional Form peuvent donner des erreurs d'interprétation lors de leur évaluation.

Pour une présentation locale, il suffit de sélectionner les cellules concernées et de cocher Cell > Display As >
Traditional Form (ou Shift-Ctrl-T).

Voici quelques expressions mathématiques en Standard et Traditional Form.

Des entrées :
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StandardForm

(1+x)% Py [x]

TraditionalForm

(x+ 1) Py(x)

Des sorties :

StandardForm

Integrate[£f[x], x]

Jf[x] dx

TraditionalForm

Integrate[£f[x], x]
ff(x)dx

m Notations mathématiques

Pour insérer des notations mathématiques, le rédacteur choisit entre l'utilisation des palettes (ensemble de boutons

cliquables), ou l'apprentissage de quelques raccourcis claviers.

Bien que les palettes soient une bonne méthode pour embrasser l'ensemble des symboles disponibles, elles néces-
sitent des va-et-vient entre la souris et le clavier qui ralentissent la frappe. Les raccourcis clavier ainsi que le
principe du double Echap embrassant un mot clef permettent la saisie aisée de puissances, indices, racines carrées,
barres de fractions...sans interrompre le processus de frappe/rédaction.

Caractéres spéciaux
Cette section regroupe les caracteres spéciaux, par opposition aux fractions qui sont constituées de plusieurs
symboles et considérées comme de la mise en forme evoluée.

L'acces est standardisé, puisque leur saisie demande la frappe d'un code embrassé par la touche Echap.
Par exemple, les lettres grecques sont accessibles en tapant leur initial entre deux touches Echap : napy...

De méme les signes union, le ET, OU, l'implication, intégrale, borne d'intervalle d'entier s'obtiennent en tapant
(toujours entre deux Echap) une expression raccourcie canonique (selon le code informatique) : && pour A, =>

pour =, un pour |, int pour ﬁ [[ pour [.
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Caracteére Nom complet Alias

o \ [Alpha] [est] a [esc

B \ [Beta] B¢ b [c]

7 \ [Pi] [t pi

J \ [Integral] int
d (opérateur différentiel) \ [DifferentialD] [£st] dd [est]

Extrait de HelpBrowser/Getting Started/Working with Notebooks/Entering Mathematical Notations

Mathematica permet aussi l'utilisation de la palette Basic Type Setting qui donne accés aux principaux symboles.
Un passage de la souris sur les symboles permet (parfois) de connaitre le raccourci correspondant.

= Puissances, indices, racines et fractions
Pour les indices, exposants, la barre de fraction et la racine carrée, il faut connaitre des raccourcis spécifiques qui
combinent la touche Ctrl avec une touche représentative de la mise en forme attendue (ici respectivement le Ctrl _,
et Ctrl »ou (Ctrl 6), le Ctrl/ etle Ctrl 2).

Action Raccourcis Resultat
puissance x G A3 x3
fraction {/]3 =
racine carrée N 2Jx Vx
indice x[crdd_[3 X3
sortir le curseur de la formule [CTRUJ-[sPacE]

Extrait de HelpBrowser/Getting Started/Working with Notebooks/Entering Mathematical Notations
= Tables et Matrices

Les tableaux et les matrices sont accessibles via Input > Creat Table/Matrice qui permet ensuite de configurer
leurs dimensions. Pour naviguer dans les éléments, utiliser 7ab.

(22
a 5
Dans ce cas encore, des raccourcis sont disponibles :

Action Raccourci

Ajoute une colonne

Ajoute une ligne
Extrait de HelpBrowser/Getting Started/Working with Notebooks/Entering Mathematical Notations

Pour afficher un tableau sous forme de matrice, il suffit de placer des parenthéses autour de celui-ci.
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4- Les feuilles de style

H Les feuilles prédéfinies

Afin de structurer un document, Mathematica dispose de plusieurs attributs de structure qui sont, pour les princi-

paux, le Titre, la Section, 1a Sous-section et le Texte.

Le rédacteur sélectionne l'attribut qu'il souhaite affecter a sa saisie en utilisant un menu déroulant (en haut a
gauche de la barre de rédaction), ou via les raccourcis Shift-Alt- nombre de 1 4 7.

A chacun de ces attributs de structure sont associées des propriétés de présentations (police, taille, casse,
couleur,...). L'ensemble de ces propriétés sont regroupées dans une feuille de style (Style Sheet). Le rédacteur peut
utiliser les différentes feuilles de style prédéfinies dans Format > Edit Style Sheet.

A noter qu'en fonction de la feuille de style choisie apparaissent de nouveaux attributs de structure.

m Création de feuille de style

Pour une meilleur présentation, la création d'un modéle regroupant ses propres propriétés de présentation est
possible : mettre les titres en Arial 12 pt, en gras et souligné tandis que le texte sera en Times 10 pt et en italique
par exemple.

Pour ce faire, le plus simple est de choisir une feuille de style préexistante qui comporte le maximum d'attributs de
structures désirées. Il s'agira ensuite de modifier les propriétés de présentations a sa convenance.

Une fois la feuille choisie, on accéde aux modifications via Format > Edit Style Sheet.... Mathematica propose
alors de modifier une Private ou Shared Style Sheet.

La premiére option permettra de sauvegarder son travail sous un nouveau style de feuille qui sera accessible dans
le menu Format > Edit Style Sheet.

La seconde permet de modifier le style du cahier en cours uniquement. Cette seconde solution permet l'inclusion
de la feuille de style dans le cahier lors de sa sauvegarde, ce qui facilite I'envoi du travail par e-mail (dans le
premier cas, il faudrait envoyer le fichier de feuille de style en sus du cahier).

Ceci choisi, un nouveau cahier apparait, comportant chacun des attributs de structure de la feuille de style : pour
modifier les propriétés de présentation, il suffit de modifier la présentation de l'attribut correspondant dans ce
cahier (eg Pour avoir un titre en bleu, sélectionner Title et choisir Format >TextColor>Blue).

Le rédacteur peut aussi ajouter des symboles en marge du texte (dingbats), des filets, modifier la tabulation, etc.

Une autre fagon d'acceder a ces mémes informations (et méme plus) consiste a utiliser I'Option Inspector via Edit
>Preference. En choisissant Notebook dans le menu déroulant et en accédant aux différents attributs des cellules
ou des graphiques par le développement des sections, on modifie les propriétés concernées (par exemple le cen-
trage des graphes, l'affichage des crochets des cellules, leur couleur, la couleur de fond de la page, l'en-téte, les
pieds de pages,etc).

Un_exemple_: Comment afficher les triangles qui permettent le déroulement du contenu des parties par un clic de
souris.

Choisir Edit > Preference pour accéder a I'Option Inspector, de sélectionner Notebook dans le menu dérou-
lant, puis de choisir Cell Options > Display Options > ShowGroupOpenCloselcon. Afin que tout soit
complet on peut aussi désélectionner ShowCellBrackets.

5- Présentation évoluée

Cette partie présente comment créer de nouvelles notatoins et comment gérer les compteurs afin de numéroter
parties et équations.

m Présentation

= Notations

La bibliotheque Notation permet la définition de nouvelles notations non disponibles par défaut. Ici encore, elle est
disponible via les lignes de commandes, ou via la palette Notation.

Exemple : Définition d'une loi de groupe pour G

<< Utilities Notation"

Notation[x_ .gy_ < PlusGroup[x , y_]]

PlusGroup[a, b]

a.gb

H Structure

= Gestion des compteurs

Les compteurs fonctionnent de la méme maniére que sous IRTgX : c'est un objet virtuel qui s'incrémente automa-
tiquement et permet de numéroter parties et équations lorsque 1'on demande son affichage. On peut utiliser plu-
sieurs compteurs afin de préciser les numérotations en fonction des parties, sous parties, etc.

Pour numéroter les Section, il suffit de placer le curseur a l'endroit ou le compteur devra s'afficher, de sélectionner
Input > Create Autonumbering Object puis de choisir le type d'objet qui incrémentera le compteur (Section)
ainsi que l'origine du compteur (a priori This counter object).

Pour numéroter les Sous-sections, il suffit d'opérer de méme. Si l'on veut obtenir un résultat dépendant de la
section (du type 3.3), il suffit d'insérer deux objets numérotés, le premier dépendant de Section et le second de
Sous-section.

De la méme fagon, on peut numéroter les équations...a condition d'avoir défini un type équation dans la feuille de
style (d'ou I'intérét d'avoir choisi la bonne feuille de style de départ, comme Article Classic).

Attention cependant, il reste un petit probléme de rafraichissement qui fait que les compteurs ne se mettent pas
immédiatement a jour aprés une modification.
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6- AuthorTools

AuthorTools est un ensemble de palettes qui fournit les outils nécessaires a la création de documents textes impor-
tants. L'auteur se voit guider dans la création d'ouvrages multifichiers, d'index, de sommaire (7able Of Content)
ainsi que dans la mise en page impression.

On remarquera la réparation de cahier qui rendra bien des services a tous les utilisateurs.

La palette principale est accessible via File > Palette > AuthorTools.

Création du projet

Le plus simple est de réserver un répertoire par projet. En choisissant Make Project, 'auteur fournit le nom de
celui-ci, le répertoire de travail ainsi que les différents cahiers qui le composeront.

Création d'index

11 faut tout d'abord préparer les documents. Le bouton Makelndex de la palette principale donne accés aux outils
nécessaires.

En sélectionnant les mots souhaités un par un et directement dans le document puis en cliquant sur Index Cell
On Selection, des Tags sont ajoutés aux cellules les contenants (on peut d'ailleurs les faire apparaitre via Find >
Show Cell Tags, ce qui ajoute des retours chariots en début de cellule qui n'influent pas sur le document
imprimeé).

Aprés avoir paginé le document, il suffit ensuite de générer l'index en choisissant parmi les quatres styles Simple,

Book, Two Column et Browser.

On peut ensuite éditer I'index ainsi construit pour retoucher les mots insérés : il suffit de sélectionner dans le cahier
source les cellules concernées et de choisir Edit Notebook Index... La modification directe du cahier contenant

I'index est possible également (pour ajouter les repéres alphabétiques, changer la présentation...).

Création de sommaire

La création de sommaire est trés similaire a celle de I'index, si ce n'est une petite manipulation astucieuse.

Apres avoir implanté les différents compteurs, il faut sélectionner I'ensemble du document et transformer tous ces
compteurs dynamiques en caractéres statiques (Input > Convert Automatic Objects to Literal). Dans le cas
contraire, la numérotation des parties, sous-parties,... sera remplacée par un point d'interrogation dans la table des
matiéres.

Attention les compteurs ne pourront plus étre dynamiques aprés cette opération.

Les différents paramétres proposés via Make Contents sont les trois styles Simple, Book et Condensed, ansi que
les types de cellules a prendre en compte (SelectedCellStyles...).
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